eu-west region expired TLS certificate
Resolved
Full outage

Starting at Feb 15 22:29:38 2025 GMT, the SSL/TLS certificate for our regional database endpoint in AWS eu-west-1 expired, causing any TLS validation to fail. For customers validating TLS, this would have caused databases to appear unavailable. A new certificate was issued and fixed by roughly Feb 16 08:05:00 2025 GMT.

Typically this is an automated process that happens across every endpoint 30 days before expiration, but PlanetScale's automation failed and the certificate was repeatedly unable to issue.

PlanetScale has multiple levels of alerting around expired TLS certificates, and is investigating why it did not alert our infrastructure team both when it initially failed to issue, and why we did not receive an immediate alert when external tests began to fail.

Sun, Feb 16, 2025, 11:48 PM
5d ago
Affected components
Updates

Resolved

Starting at Feb 15 22:29:38 2025 GMT, the SSL/TLS certificate for our regional database endpoint in AWS eu-west-1 expired, causing any TLS validation to fail. For customers validating TLS, this would have caused databases to appear unavailable. A new certificate was issued and fixed by roughly Feb 16 08:05:00 2025 GMT.

Typically this is an automated process that happens across every endpoint 30 days before expiration, but PlanetScale's automation failed and the certificate was repeatedly unable to issue.

PlanetScale has multiple levels of alerting around expired TLS certificates, and is investigating why it did not alert our infrastructure team both when it initially failed to issue, and why we did not receive an immediate alert when external tests began to fail.

Sun, Feb 16, 2025, 11:48 PM
15h earlier...

Resolved

The issue has been resolved.

Sun, Feb 16, 2025, 08:07 AM
9h earlier...

Investigating

Connectivity to eu-west region is failing due to an expired TLS certificate

Sat, Feb 15, 2025, 10:29 PM